Bootstrapping a Puppet agent/master on Ubuntu

Though it’s really great that Puppet made it into Ubuntu’s main repository, the provided version is rather outdated which prevents you from using advanced language features when writing your manifests. So sooner or later you end up installing Puppet manually. In order to speed up installation I stripped it down to the following:

install agent:

$ bash < <(wget -qO - https://bit.ly/install-puppet-agent)

install master:

$ bash < <(wget -qO - https://bit.ly/install-puppet-master)

The call fetches the most recent version of the install script from github, installs Ubuntu’s Ruby (which is good enough for running Puppet), fetches an upstream version of gem itself and updates it to the most recent version and finally installs the Puppet gem.

You can, of course, also download, review and run the scripts manually. Just have a look at https://github.com/moviepilot/puppet/tree/master/tools

2 Gedanken zu “Bootstrapping a Puppet agent/master on Ubuntu

  1. Well, the problem with Ruby/Gem-driven software is the typical short release cycle. It’s hard to find a suitable and relieable backport provider for this and actually nearly no productive Ruby based system I know so far uses Ubuntu’s gem provider.

    So, of course you are right, backports are a nice work around for a lot of packaging problems, regarding Ruby related stuff it’s rather uncommon (e.g. some gems rely on a recent version of Rubygems, if you have a pre packaged one, you cannot install some gems and so on).

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>